summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_1.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
new file mode 100644
index 0000000000..c52f2830b8
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_1.13.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
2HOMEPAGE = "http://www.lesswatts.org/"
3BUGTRACKER = "http://bugzilla.lesswatts.org/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8DEPENDS = "virtual/libintl ncurses"
9
10# powertop 1.13 needs lspci
11REPENDS_${PN} = "pciutils"
12
13PR = "r0"
14
15SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
16
17CFLAGS += "${LDFLAGS}"
18EXTRA_OEMAKE = "VERSION=\"${PV}\""
19
20do_configure() {
21 # We do not build ncurses with wide char support
22 sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
23}
24
25do_install() {
26 oe_runmake install DESTDIR=${D}
27}
28