summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_1.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_1.11.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.11.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.11.bb b/meta/recipes-kernel/powertop/powertop_1.11.bb
new file mode 100644
index 0000000000..371fc62e35
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_1.11.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
2HOMEPAGE = "http://www.linuxpowertop.org/"
3BUGTRACKER = "http://bugzilla.lesswatts.org/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8DEPENDS = "virtual/libintl ncurses"
9
10PR = "r0"
11
12SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
13
14CFLAGS += "${LDFLAGS}"
15
16do_configure() {
17 # We do not build ncurses with wide char support
18 sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
19}
20
21do_install() {
22 oe_runmake install DESTDIR=${D}
23}