summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf_3.4.bb')
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
new file mode 100644
index 0000000000..997beb4aef
--- /dev/null
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
11
12PR = "r0"
13
14BUILDPERF_libc-uclibc = "no"
15
16DEPENDS = "virtual/kernel \
17 virtual/${MLPREFIX}libc \
18 ${MLPREFIX}elfutils \
19 ${MLPREFIX}binutils \
20 "
21RDEPENDS_${PN} += "elfutils perl python"
22
23PROVIDES = "virtual/perf"
24
25inherit kernel-arch
26
27S = "${STAGING_KERNEL_DIR}"
28B = "${WORKDIR}/${BPN}-${PV}"
29
30EXTRA_OEMAKE = \
31 '-C ${S}/tools/perf \
32 O=${B} \
33 CROSS_COMPILE=${TARGET_PREFIX} \
34 ARCH=${ARCH} \
35 CC="${CC}" \
36 AR="${AR}" \
37 prefix=/usr \
38 NO_GTK2=1 NO_NEWT=1 NO_DWARF=1 \
39 '
40
41do_compile() {
42 oe_runmake all
43}
44
45do_install() {
46 oe_runmake DESTDIR=${D} install
47}
48
49PACKAGE_ARCH = "${MACHINE_ARCH}"
50