summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 8112986a08..ea7571aa8e 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -129,7 +129,8 @@ do_configure_prepend () {
129 # config/Makefile. 129 # config/Makefile.
130 if [ -e "${S}/tools/perf/config/Makefile" ]; then 130 if [ -e "${S}/tools/perf/config/Makefile" ]; then
131 # Match $(prefix)/$(lib) and $(prefix)/lib 131 # Match $(prefix)/$(lib) and $(prefix)/lib
132 sed -i 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \ 132 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
133 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
133 ${S}/tools/perf/config/Makefile 134 ${S}/tools/perf/config/Makefile
134 fi 135 fi
135 # We need to ensure the --sysroot option in CC is preserved 136 # We need to ensure the --sysroot option in CC is preserved
@@ -163,6 +164,7 @@ RDEPENDS_${PN} += "elfutils"
163RDEPENDS_${PN}-archive =+ "bash" 164RDEPENDS_${PN}-archive =+ "bash"
164RDEPENDS_${PN}-python =+ "bash python" 165RDEPENDS_${PN}-python =+ "bash python"
165RDEPENDS_${PN}-perl =+ "bash perl perl-modules" 166RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
167RDEPENDS_${PN}-tests =+ "python"
166 168
167RSUGGESTS_SCRIPTING = "${@perf_feature_enabled('perf-scripting', '${PN}-perl ${PN}-python', '',d)}" 169RSUGGESTS_SCRIPTING = "${@perf_feature_enabled('perf-scripting', '${PN}-perl ${PN}-python', '',d)}"
168RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}" 170RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"