summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 0f5df74f11..66d3c1d325 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -153,6 +153,8 @@ python copy_perf_source_from_kernel() {
153 if os.path.isdir(src): 153 if os.path.isdir(src):
154 oe.path.copyhardlinktree(src, dest) 154 oe.path.copyhardlinktree(src, dest)
155 else: 155 else:
156 src_path = os.path.dirname(s)
157 os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
156 bb.utils.copyfile(src, dest) 158 bb.utils.copyfile(src, dest)
157} 159}
158 160