summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 4a815ff2f8..269069f3af 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -60,6 +60,11 @@ B = "${WORKDIR}/${BPN}-${PV}"
60SCRIPTING_DEFINES = "${@perf_feature_enabled('perf-scripting', '', 'NO_LIBPERL=1 NO_LIBPYTHON=1',d)}" 60SCRIPTING_DEFINES = "${@perf_feature_enabled('perf-scripting', '', 'NO_LIBPERL=1 NO_LIBPYTHON=1',d)}"
61TUI_DEFINES = "${@perf_feature_enabled('perf-tui', '', 'NO_NEWT=1',d)}" 61TUI_DEFINES = "${@perf_feature_enabled('perf-tui', '', 'NO_NEWT=1',d)}"
62 62
63# The LDFLAGS is required or some old kernels fails due missing
64# symbols and this is preferred than requiring patches to every old
65# supported kernel.
66LDFLAGS="-ldl -lutil"
67
63EXTRA_OEMAKE = \ 68EXTRA_OEMAKE = \
64 '-C ${S}/tools/perf \ 69 '-C ${S}/tools/perf \
65 O=${B} \ 70 O=${B} \
@@ -88,13 +93,13 @@ PARALLEL_MAKE = ""
88 93
89do_compile() { 94do_compile() {
90 # Linux kernel build system is expected to do the right thing 95 # Linux kernel build system is expected to do the right thing
91 unset CFLAGS LDFLAGS 96 unset CFLAGS
92 oe_runmake all 97 oe_runmake all
93} 98}
94 99
95do_install() { 100do_install() {
96 # Linux kernel build system is expected to do the right thing 101 # Linux kernel build system is expected to do the right thing
97 unset CFLAGS LDFLAGS 102 unset CFLAGS
98 oe_runmake DESTDIR=${D} install 103 oe_runmake DESTDIR=${D} install
99 # we are checking for this make target to be compatible with older perf versions 104 # we are checking for this make target to be compatible with older perf versions
100 if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then 105 if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then