summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index d2c10484e6..4a815ff2f8 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -60,7 +60,6 @@ B = "${WORKDIR}/${BPN}-${PV}"
60SCRIPTING_DEFINES = "${@perf_feature_enabled('perf-scripting', '', 'NO_LIBPERL=1 NO_LIBPYTHON=1',d)}" 60SCRIPTING_DEFINES = "${@perf_feature_enabled('perf-scripting', '', 'NO_LIBPERL=1 NO_LIBPYTHON=1',d)}"
61TUI_DEFINES = "${@perf_feature_enabled('perf-tui', '', 'NO_NEWT=1',d)}" 61TUI_DEFINES = "${@perf_feature_enabled('perf-tui', '', 'NO_NEWT=1',d)}"
62 62
63export LDFLAGS = "-ldl -lutil"
64EXTRA_OEMAKE = \ 63EXTRA_OEMAKE = \
65 '-C ${S}/tools/perf \ 64 '-C ${S}/tools/perf \
66 O=${B} \ 65 O=${B} \
@@ -72,13 +71,7 @@ EXTRA_OEMAKE = \
72 NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${SCRIPTING_DEFINES} \ 71 NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${SCRIPTING_DEFINES} \
73 ' 72 '
74 73
75# We already pass the correct arguments to our compiler for the CFLAGS (if we
76# don't override it, it'll add -m32/-m64 itself). For LDFLAGS, it was failing
77# to find bfd symbols.
78EXTRA_OEMAKE += "\ 74EXTRA_OEMAKE += "\
79 'CFLAGS=${CFLAGS} -fPIC' \
80 'LDFLAGS=${LDFLAGS} -lpthread -lrt -lelf -lm -lbfd' \
81 \
82 'prefix=${prefix}' \ 75 'prefix=${prefix}' \
83 'bindir=${bindir}' \ 76 'bindir=${bindir}' \
84 'sharedir=${datadir}' \ 77 'sharedir=${datadir}' \
@@ -94,10 +87,14 @@ EXTRA_OEMAKE += "\
94PARALLEL_MAKE = "" 87PARALLEL_MAKE = ""
95 88
96do_compile() { 89do_compile() {
90 # Linux kernel build system is expected to do the right thing
91 unset CFLAGS LDFLAGS
97 oe_runmake all 92 oe_runmake all
98} 93}
99 94
100do_install() { 95do_install() {
96 # Linux kernel build system is expected to do the right thing
97 unset CFLAGS LDFLAGS
101 oe_runmake DESTDIR=${D} install 98 oe_runmake DESTDIR=${D} install
102 # we are checking for this make target to be compatible with older perf versions 99 # we are checking for this make target to be compatible with older perf versions
103 if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then 100 if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then