summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofile_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofile_cvs.bb')
-rw-r--r--meta/recipes-kernel/oprofile/oprofile_cvs.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofile_cvs.bb b/meta/recipes-kernel/oprofile/oprofile_cvs.bb
new file mode 100644
index 0000000000..dd8dd58863
--- /dev/null
+++ b/meta/recipes-kernel/oprofile/oprofile_cvs.bb
@@ -0,0 +1,27 @@
1PV = "0.9.4+cvs${SRCDATE}"
2PR = "r0"
3SECTION = "devel"
4DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
5of profiling all running code at low overhead."
6LICENSE = "GPL"
7DEPENDS = "popt binutils"
8RDEPENDS = "binutils-symlinks"
9RRECOMMENDS = "kernel-vmlinux"
10
11DEFAULT_PREFERENCE = "-1"
12
13SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
14 file://opstart.patch;patch=1 \
15 file://acinclude.m4"
16S = "${WORKDIR}/oprofile"
17
18inherit autotools
19
20EXTRA_OECONF = "--with-kernel-support \
21 --without-x \
22 --disable-werror "
23
24do_configure () {
25 cp ${WORKDIR}/acinclude.m4 ${S}/
26 autotools_do_configure
27}