summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofile_0.9.6.bb')
-rw-r--r--meta/recipes-kernel/oprofile/oprofile_0.9.6.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb b/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
new file mode 100644
index 0000000000..9679411bec
--- /dev/null
+++ b/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
2of profiling all running code at low overhead."
3HOMEPAGE = "http://oprofile.sourceforge.net/news/"
4BUGTRACKER = "http://sourceforge.net/tracker/?group_id=16191&atid=116191"
5
6LICENSE = "LGPLv2.1+ & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://libopagent/opagent.h;beginline=5;endline=26;md5=4f16f72c7a493d8a4704aa18d03d15c6 \
9 file://daemon/liblegacy/p_module.h;beginline=2;endline=20;md5=fc23a43455edf185307274a99730b6e4"
10
11SECTION = "devel"
12
13DEPENDS = "popt binutils"
14RDEPENDS = "binutils-symlinks"
15RRECOMMENDS = "kernel-vmlinux"
16
17PR = "r0"
18
19SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
20 file://opstart.patch \
21 file://acinclude.m4"
22S = "${WORKDIR}/oprofile-${PV}"
23
24inherit autotools
25
26EXTRA_OECONF = "--with-kernel-support --without-x"
27
28do_configure () {
29 cp ${WORKDIR}/acinclude.m4 ${S}/
30 autotools_do_configure
31}