summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/modutils/modutils-collateral.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/modutils/modutils-collateral.bb')
-rw-r--r--meta/recipes-kernel/modutils/modutils-collateral.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/modutils/modutils-collateral.bb b/meta/recipes-kernel/modutils/modutils-collateral.bb
new file mode 100644
index 0000000000..6d010a5754
--- /dev/null
+++ b/meta/recipes-kernel/modutils/modutils-collateral.bb
@@ -0,0 +1,21 @@
1SECTION = "base"
2DESCRIPTION = "modutils configuration files"
3PR = "r3"
4LICENSE = "MIT"
5
6SRC_URI = "file://modules \
7 file://modules.conf"
8
9do_compile () {
10}
11
12do_install () {
13 install -d ${D}${sysconfdir}
14 install -m 0644 ${WORKDIR}/modules ${D}${sysconfdir}/modules
15 if [ ${MAJOR_KERNEL_VERSION}=2.6 ]; then
16 install -d ${D}${sysconfdir}/modprobe.d
17 else
18 install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
19 fi
20
21}