summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb')
-rw-r--r--meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
index c7edb20ee4..32b89bb5ea 100644
--- a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
+++ b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
@@ -1,8 +1,9 @@
1SUMMARY = "Build tools needed by external modules" 1SUMMARY = "Build tools needed by external modules"
2HOMEPAGE = "https://www.yoctoproject.org/"
2LICENSE = "GPLv2" 3LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 5
5inherit kernel-arch 6inherit kernel-arch linux-kernel-base
6inherit pkgconfig 7inherit pkgconfig
7 8
8PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -15,8 +16,10 @@ do_compile[depends] += "virtual/kernel:do_compile_kernelmodules"
15RDEPENDS_${PN}-dev = "" 16RDEPENDS_${PN}-dev = ""
16 17
17DEPENDS += "bc-native bison-native" 18DEPENDS += "bc-native bison-native"
19DEPENDS += "gmp-native"
18 20
19EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}"" 21EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
22EXTRA_OEMAKE += " HOSTCXX="${BUILD_CXX} ${BUILD_CXXFLAGS} ${BUILD_LDFLAGS}" CROSS_COMPILE=${TARGET_PREFIX}"
20 23
21# Build some host tools under work-shared. CC, LD, and AR are probably 24# Build some host tools under work-shared. CC, LD, and AR are probably
22# not used, but this is the historical way of invoking "make scripts". 25# not used, but this is the historical way of invoking "make scripts".