summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb b/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
index 13bab9068e..9d21fb00bf 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
@@ -63,11 +63,11 @@ do_install_append () {
63} 63}
64 64
65do_install_ptest () { 65do_install_ptest () {
66 for f in Makefile tests/Makefile tests/utils/utils.sh ; do 66 for f in Makefile tests/Makefile tests/utils/utils.sh tests/regression/tools/save-load/load-42*.lttng tests/regression/tools/save-load/configuration/load-42*.lttng ; do
67 install -D "${B}/$f" "${D}${PTEST_PATH}/$f" 67 install -D "${B}/$f" "${D}${PTEST_PATH}/$f"
68 done 68 done
69 69
70 for f in config/tap-driver.sh config/test-driver ; do 70 for f in config/tap-driver.sh config/test-driver src/common/config/session.xsd src/common/mi-lttng-3.0.xsd; do
71 install -D "${S}/$f" "${D}${PTEST_PATH}/$f" 71 install -D "${S}/$f" "${D}${PTEST_PATH}/$f"
72 done 72 done
73 73
@@ -141,8 +141,17 @@ do_install_ptest () {
141 -e 's#\(^test.*LDADD.=\)#disable\1#g' \ 141 -e 's#\(^test.*LDADD.=\)#disable\1#g' \
142 -i ${D}${PTEST_PATH}/tests/unit/Makefile 142 -i ${D}${PTEST_PATH}/tests/unit/Makefile
143 143
144 #
145 # Disable notification tools tests as currently
146 # these hang and cause the rest of the ptests to timeout
147 #
148 sed -e 's#tools/notification/test_notification_ust##g' \
149 -e 's#tools/notification/test_notification_kernel##g' \
150 -e 's#tools/notification/test_notification_multi_app##g' \
151 -i ${D}${PTEST_PATH}/tests/regression/Makefile
152
144 # Substitute links to installed binaries. 153 # Substitute links to installed binaries.
145 for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd ; do 154 for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd lttng-crash; do
146 exedir="${D}${PTEST_PATH}/src/bin/${prog}" 155 exedir="${D}${PTEST_PATH}/src/bin/${prog}"
147 install -d "$exedir" 156 install -d "$exedir"
148 case "$prog" in 157 case "$prog" in