summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.9.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.9.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.9.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.9.3.bb
new file mode 100644
index 0000000000..acd76b54b3
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.9.3.bb
@@ -0,0 +1,33 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=362844633a08753bd96ab322a6c7f9f6 \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9inherit module
10
11COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux'
12
13SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
14 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
15 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch"
16
17SRC_URI[md5sum] = "9abf694dddcc197988189ef65b496f4c"
18SRC_URI[sha256sum] = "f911bca81b02a787474f3d100390dad7447f952525e6d041f50991940246bafe"
19
20export INSTALL_MOD_DIR="kernel/lttng-modules"
21
22EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
23
24do_install_append() {
25 # Delete empty directories to avoid QA failures if no modules were built
26 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
27}
28
29python do_package_prepend() {
30 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
31 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
32}
33