summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.9.0.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.9.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.9.0.bb b/meta/recipes-kernel/lttng/lttng-modules_2.9.0.bb
new file mode 100644
index 0000000000..e59d6bc137
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.9.0.bb
@@ -0,0 +1,32 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=362844633a08753bd96ab322a6c7f9f6 \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9inherit module
10
11COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux'
12
13SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
14 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch"
15
16SRC_URI[md5sum] = "717df375ccb6f32bb297cc2f2e692bbf"
17SRC_URI[sha256sum] = "af914e5954081cfb6bd4c6dcf9390474e0c13fe056b12b3dfc86d1b88b8340a0"
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20
21EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
22
23do_install_append() {
24 # Delete empty directories to avoid QA failures if no modules were built
25 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
26}
27
28python do_package_prepend() {
29 if not os.path.exists(os.path.join(d.getVar('D'), 'lib/modules')):
30 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
31}
32