summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.5.2.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.5.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.5.2.bb b/meta/recipes-kernel/lttng/lttng-modules_2.5.2.bb
new file mode 100644
index 0000000000..55df07f632
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.5.2.bb
@@ -0,0 +1,39 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10do_configure[depends] += "virtual/kernel:do_install"
11
12inherit module
13
14SRCREV = "16d7431c3a78605ea598dbd3f081a2b1a8463f23"
15
16COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|arm).*-linux'
17
18SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.5 \
19 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
20 file://Fix-noargs-probes-should-calculate-alignment-and-eve.patch \
21 file://Update-kvm-instrumentation-compile-on-3.17-rc1.patch \
22 "
23
24export INSTALL_MOD_DIR="kernel/lttng-modules"
25export KERNEL_SRC="${STAGING_KERNEL_DIR}"
26
27
28S = "${WORKDIR}/git"
29
30do_install_append() {
31 # Delete empty directories to avoid QA failures if no modules were built
32 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
33}
34
35python do_package_prepend() {
36 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
37 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
38}
39