summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.4.2.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.4.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.4.2.bb b/meta/recipes-kernel/lttng/lttng-modules_2.4.2.bb
new file mode 100644
index 0000000000..1967631626
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.4.2.bb
@@ -0,0 +1,38 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10
11inherit module
12
13SRCREV = "85016adfb21268836df48dfb5cda106391e72fd1"
14PV = "2.4.2"
15
16# lttng currently blacklists arm with gcc-4.8
17COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips).*-linux'
18
19SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.4 \
20 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
21 "
22
23export INSTALL_MOD_DIR="kernel/lttng-modules"
24export KERNEL_SRC="${STAGING_KERNEL_DIR}"
25
26
27S = "${WORKDIR}/git"
28
29do_install_append() {
30 # Delete empty directories to avoid QA failures if no modules were built
31 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
32}
33
34python do_package_prepend() {
35 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
36 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
37}
38