diff options
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.4.1.bb')
-rw-r--r-- | meta/recipes-kernel/lttng/lttng-modules_2.4.1.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.4.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.4.1.bb new file mode 100644 index 0000000000..4ef74dd1cb --- /dev/null +++ b/meta/recipes-kernel/lttng/lttng-modules_2.4.1.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SECTION = "devel" | ||
2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" | ||
3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" | ||
4 | LICENSE = "LGPLv2.1 & GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \ | ||
6 | file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \ | ||
7 | file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad" | ||
8 | |||
9 | DEPENDS = "virtual/kernel" | ||
10 | |||
11 | inherit module | ||
12 | |||
13 | SRCREV = "afdc6b155161f209fcfadc5288dc017ceab56353" | ||
14 | PV = "2.4.1" | ||
15 | |||
16 | # lttng currently blacklists arm with gcc-4.8 | ||
17 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips).*-linux' | ||
18 | |||
19 | SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.4 \ | ||
20 | file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \ | ||
21 | " | ||
22 | |||
23 | export INSTALL_MOD_DIR="kernel/lttng-modules" | ||
24 | export KERNEL_SRC="${STAGING_KERNEL_DIR}" | ||
25 | |||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | do_install_append() { | ||
30 | # Delete empty directories to avoid QA failures if no modules were built | ||
31 | find ${D}/lib -depth -type d -empty -exec rmdir {} \; | ||
32 | } | ||
33 | |||
34 | python do_package_prepend() { | ||
35 | if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')): | ||
36 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True)) | ||
37 | } | ||
38 | |||