summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
new file mode 100644
index 0000000000..f293376e1e
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
@@ -0,0 +1,34 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10
11inherit module
12
13SRCREV = "eef112db0e63feff6cbf0a98cda9af607cefb377"
14PV = "2.3.3"
15
16SRC_URI = "git://git.lttng.org/lttng-modules.git \
17 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20export KERNEL_SRC="${STAGING_KERNEL_DIR}"
21
22
23S = "${WORKDIR}/git"
24
25do_install_append() {
26 # Delete empty directories to avoid QA failures if no modules were built
27 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
28}
29
30python do_package_prepend() {
31 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
32 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
33}
34