summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
new file mode 100644
index 0000000000..a959ce9211
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.3.bb
@@ -0,0 +1,44 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPLv2.1 & GPLv2 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2"
13# Use :append here so that the patch is applied also when using devupstream
14SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
15
16SRC_URI[sha256sum] = "7cf1acbb50b84116acc9b4281b81dcc2643d6018bbd1e8514ad1270239896c4b"
17
18export INSTALL_MOD_DIR="kernel/lttng-modules"
19
20EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
21
22MODULES_MODULE_SYMVERS_LOCATION = "src"
23
24do_install:append() {
25 # Delete empty directories to avoid QA failures if no modules were built
26 if [ -d ${D}/${nonarch_base_libdir} ]; then
27 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
28 fi
29}
30
31python do_package:prepend() {
32 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
33 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
34}
35
36BBCLASSEXTEND = "devupstream:target"
37LIC_FILES_CHKSUM:class-devupstream = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
38DEFAULT_PREFERENCE:class-devupstream = "-1"
39SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
40
41SRCREV:class-devupstream = "c570be0da77e963d77bac099d468bc0cd5f1bd63"
42PV:class-devupstream = "2.13.0+git${SRCPV}"
43S:class-devupstream = "${WORKDIR}/git"
44SRCREV_FORMAT ?= "lttng_git"