summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb
new file mode 100644
index 0000000000..3515e4f51e
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb
@@ -0,0 +1,49 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
6
7inherit module
8
9include lttng-platforms.inc
10
11SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
13 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
14 file://0001-fix-btrfs-tracepoints-output-proper-root-owner-for-t.patch \
15 file://0007-fix-objtool-Rename-frame.h-objtool.h-v5.10.patch \
16 file://0009-fix-btrfs-make-ordered-extent-tracepoint-take-btrfs_.patch \
17 file://0010-fix-ext4-fast-commit-recovery-path-v5.10.patch \
18 file://0012-fix-kvm-x86-mmu-Add-TDP-MMU-PF-handler-v5.10.patch \
19 file://0014-fix-tracepoint-Optimize-using-static_call-v5.10.patch \
20 file://0016-fix-statedump-undefined-symbols-caused-by-incorrect-.patch \
21 "
22
23SRC_URI[sha256sum] = "673ef85c9f03e9b8fed10795e09d4e68add39404b70068d08b10f7b85754d7f0"
24
25export INSTALL_MOD_DIR="kernel/lttng-modules"
26
27EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
28
29do_install_append() {
30 # Delete empty directories to avoid QA failures if no modules were built
31 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
32}
33
34python do_package_prepend() {
35 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
36 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
37}
38
39BBCLASSEXTEND = "devupstream:target"
40LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
41DEFAULT_PREFERENCE_class-devupstream = "-1"
42SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.12 \
43 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
44 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
45 "
46SRCREV_class-devupstream = "be71b60a327d7ad2588abc5cad2861177119972b"
47PV_class-devupstream = "2.12.3+git${SRCPV}"
48S_class-devupstream = "${WORKDIR}/git"
49SRCREV_FORMAT ?= "lttng_git"