diff options
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.12.2.bb')
-rw-r--r-- | meta/recipes-kernel/lttng/lttng-modules_2.12.2.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.12.2.bb b/meta/recipes-kernel/lttng/lttng-modules_2.12.2.bb new file mode 100644 index 0000000000..49b7a116bc --- /dev/null +++ b/meta/recipes-kernel/lttng/lttng-modules_2.12.2.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | SECTION = "devel" | ||
2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" | ||
3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" | ||
4 | LICENSE = "LGPLv2.1 & GPLv2 & MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128" | ||
6 | |||
7 | inherit module | ||
8 | |||
9 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux' | ||
10 | |||
11 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ | ||
12 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ | ||
13 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[sha256sum] = "df50bc3bd58679705714f17721acf619a8b0cedc694f8a97052aa5099626feca" | ||
17 | |||
18 | export INSTALL_MOD_DIR="kernel/lttng-modules" | ||
19 | |||
20 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" | ||
21 | |||
22 | do_install_append() { | ||
23 | # Delete empty directories to avoid QA failures if no modules were built | ||
24 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; | ||
25 | } | ||
26 | |||
27 | python do_package_prepend() { | ||
28 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): | ||
29 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) | ||
30 | } | ||
31 | |||
32 | BBCLASSEXTEND = "devupstream:target" | ||
33 | LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128" | ||
34 | DEFAULT_PREFERENCE_class-devupstream = "-1" | ||
35 | SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.12 \ | ||
36 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ | ||
37 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ | ||
38 | " | ||
39 | SRCREV_class-devupstream = "11441f8f17f7825f529e2f6c54d3605771709260" | ||
40 | PV_class-devupstream = "2.12.1+git${SRCPV}" | ||
41 | S_class-devupstream = "${WORKDIR}/git" | ||
42 | SRCREV_FORMAT ?= "lttng_git" | ||