summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.11.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.11.9.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.11.9.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.11.9.bb b/meta/recipes-kernel/lttng/lttng-modules_2.11.9.bb
new file mode 100644
index 0000000000..8e9c44241b
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.11.9.bb
@@ -0,0 +1,50 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPLv2.1 & GPLv2 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
7
8inherit module
9
10COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
14 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
15 file://0017-fix-random-remove-unused-tracepoints-v5.18.patch \
16 file://0018-fix-random-remove-unused-tracepoints-v5.10-v5.15.patch \
17 file://0019-fix-random-tracepoints-removed-in-stable-kernels.patch \
18 file://fix-jbd2-use-the-correct-print-format.patch \
19 "
20
21SRC_URI[md5sum] = "cfb23ea6bdaf1ad40c7f9ac098b4016d"
22SRC_URI[sha256sum] = "0c5fe9f8d8dbd1411a3c1c643dcbd0a55577bd15845758b73948e00bc7c387a6"
23
24export INSTALL_MOD_DIR="kernel/lttng-modules"
25
26EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
27
28do_install_append() {
29 # Delete empty directories to avoid QA failures if no modules were built
30 if [ -d ${D}/${nonarch_base_libdir} ]; then
31 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
32 fi
33}
34
35python do_package_prepend() {
36 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
37 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
38}
39
40BBCLASSEXTEND = "devupstream:target"
41LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
42DEFAULT_PREFERENCE_class-devupstream = "-1"
43SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.11 \
44 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
45 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
46 "
47SRCREV_class-devupstream = "17c413953603f063f2a9d6c3788bec914ce6f955"
48PV_class-devupstream = "2.11.2+git${SRCPV}"
49S_class-devupstream = "${WORKDIR}/git"
50SRCREV_FORMAT ?= "lttng_git"