summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb b/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
deleted file mode 100644
index 26c247e169..0000000000
--- a/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
6
7inherit module
8
9COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
10
11SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
13 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
14 file://0001-fix-strncpy-equals-destination-size-warning.patch \
15 file://0002-fix-objtool-Rename-frame.h-objtool.h-v5.10.patch \
16 file://0003-fix-btrfs-tracepoints-output-proper-root-owner-for-t.patch \
17 file://0004-fix-btrfs-make-ordered-extent-tracepoint-take-btrfs_.patch \
18 file://0005-fix-ext4-fast-commit-recovery-path-v5.10.patch \
19 file://0006-fix-KVM-x86-Add-intr-vectoring-info-and-error-code-t.patch \
20 file://0007-fix-kvm-x86-mmu-Add-TDP-MMU-PF-handler-v5.10.patch \
21 file://0008-fix-KVM-x86-mmu-Return-unique-RET_PF_-values-if-the-.patch \
22 file://0009-fix-tracepoint-Optimize-using-static_call-v5.10.patch \
23 file://0010-fix-include-order-for-older-kernels.patch \
24 file://0011-Add-release-maintainer-script.patch \
25 file://0012-Improve-the-release-script.patch \
26 file://0013-fix-backport-of-fix-ext4-fast-commit-recovery-path-v.patch \
27 file://0014-Revert-fix-include-order-for-older-kernels.patch \
28 file://0015-fix-backport-of-fix-tracepoint-Optimize-using-static.patch \
29 file://0016-fix-adjust-version-range-for-trace_find_free_extent.patch \
30 "
31
32SRC_URI[md5sum] = "8ef09fdfcdec669d33f7fc1c1c80f2c4"
33SRC_URI[sha256sum] = "23372811cdcd2ac28ba8c9d09484ed5f9238cfbd0043f8c663ff3875ba9c8566"
34
35export INSTALL_MOD_DIR="kernel/lttng-modules"
36
37EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
38
39do_install_append() {
40 # Delete empty directories to avoid QA failures if no modules were built
41 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
42}
43
44python do_package_prepend() {
45 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
46 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
47}
48
49BBCLASSEXTEND = "devupstream:target"
50LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
51DEFAULT_PREFERENCE_class-devupstream = "-1"
52SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.11 \
53 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
54 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
55 "
56SRCREV_class-devupstream = "17c413953603f063f2a9d6c3788bec914ce6f955"
57PV_class-devupstream = "2.11.2+git${SRCPV}"
58S_class-devupstream = "${WORKDIR}/git"
59SRCREV_FORMAT ?= "lttng_git"