summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.10.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.10.6.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.10.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.10.6.bb b/meta/recipes-kernel/lttng/lttng-modules_2.10.6.bb
new file mode 100644
index 0000000000..6146966894
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.10.6.bb
@@ -0,0 +1,35 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \
8 "
9
10inherit module
11
12COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux'
13
14SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
16 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
17"
18
19SRC_URI[md5sum] = "8110099f4615fc89a74ffe9189b56cfc"
20SRC_URI[sha256sum] = "04a080c81743eb29d181bac29ceb0c15819a2f4210793f2cc9958d885435029f"
21
22export INSTALL_MOD_DIR="kernel/lttng-modules"
23
24EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
25
26do_install_append() {
27 # Delete empty directories to avoid QA failures if no modules were built
28 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
29}
30
31python do_package_prepend() {
32 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
33 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
34}
35