summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb b/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb
new file mode 100644
index 0000000000..1c24e94902
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb
@@ -0,0 +1,46 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \
8 "
9
10inherit module
11
12COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
13
14SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
16 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
17 "
18
19SRC_URI[md5sum] = "3e9ed67a2da17edf93194f8a5e75a246"
20SRC_URI[sha256sum] = "d0ba614a9cac3daf8ac034837f8b786e6be2ce0242aeecef7096bed5e03b762c"
21
22export INSTALL_MOD_DIR="kernel/lttng-modules"
23
24EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
25
26do_install_append() {
27 # Delete empty directories to avoid QA failures if no modules were built
28 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
29}
30
31python do_package_prepend() {
32 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
33 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
34}
35
36BBCLASSEXTEND = "devupstream:target"
37LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3"
38DEFAULT_PREFERENCE_class-devupstream = "-1"
39SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.10 \
40 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
41 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
42 "
43SRCREV_class-devupstream = "b34304f146ea234ea764580d7ce1b03d05a215f9"
44PV_class-devupstream = "2.10.14+git${SRCPV}"
45S_class-devupstream = "${WORKDIR}/git"
46SRCREV_FORMAT ?= "lttng_git"