summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb
new file mode 100644
index 0000000000..1be0fc15c3
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb
@@ -0,0 +1,29 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10
11inherit module
12
13SRCREV = "b374c356eb4827b68754d68adc0f1c94b5de9faa"
14PV = "2.1.1"
15PR = "r0"
16
17SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
18 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
19
20export INSTALL_MOD_DIR="kernel/lttng-modules"
21export KERNEL_SRC="${STAGING_KERNEL_DIR}"
22
23
24S = "${WORKDIR}/git"
25
26# Due to liburcu not building for MIPS currently this recipe needs to
27# be limited also.
28# So here let us first suppport x86/arm/powerpc platforms now.
29COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'