summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb')
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
new file mode 100644
index 0000000000..5d34c41a34
--- /dev/null
+++ b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
@@ -0,0 +1,27 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1eb086682a7c65a45acd9bcdf6877b3e \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = virtual/kernel
10
11inherit module
12
13SRCREV = "4d3e89e379fc66480d729abe8daa5c86eb585400"
14PV = "2.0.pre11+git${SRCREV}"
15PR = "r0"
16
17SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
18 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
19
20export INSTALL_MOD_DIR="kernel/lttng-modules"
21
22S = "${WORKDIR}/git"
23
24# Due to liburcu not building for MIPS currently this recipe needs to
25# be limited also.
26# So here let us first suppport x86/arm/powerpc platforms now.
27COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'