summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux_2.6.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux_2.6.23.bb')
-rw-r--r--meta/recipes-kernel/linux/linux_2.6.23.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux_2.6.23.bb b/meta/recipes-kernel/linux/linux_2.6.23.bb
new file mode 100644
index 0000000000..5d5c21b9d3
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux_2.6.23.bb
@@ -0,0 +1,84 @@
1require linux.inc
2
3# Mark archs/machines that this kernel supports
4DEFAULT_PREFERENCE = "-1"
5DEFAULT_PREFERENCE_cm-x270 = "1"
6DEFAULT_PREFERENCE_em-x270 = "1"
7DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
8DEFAULT_PREFERENCE_mpc8323e-rdb = "1"
9
10PR = "r7"
11
12SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
13 file://binutils-buildid-arm.patch;patch=1 \
14 file://1300-fix-gcc-4.3-false-modulo-optimization.patch.patch;patch=1 \
15 file://defconfig \
16 "
17
18SRC_URI_append_em-x270 = "\
19 file://em-x270.patch;patch=1 \
20 file://em-x270-battery-sysfs-fix.patch;patch=1 "
21
22SRC_URI_append_cm-x270 = "\
23 file://0001-cm-x270-base2.patch;patch=1 \
24 file://0002-cm-x270-match-type.patch;patch=1 \
25 file://0003-cm-x270-ide.patch;patch=1 \
26 file://0004-cm-x270-it8152.patch;patch=1 \
27 file://0005-cm-x270-pcmcia.patch;patch=1 \
28 file://0006-ramdisk_load.patch;patch=1 \
29 file://0007-mmcsd_large_cards-r0.patch;patch=1 \
30 file://0008-cm-x270-nand-simplify-name.patch;patch=1 \
31 file://16bpp.patch;patch=1"
32
33CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
34
35FILES_kernel-image_cm-x270 = ""
36
37python do_compulab_image() {
38 import os
39 import os.path
40 import struct
41
42 machine = bb.data.getVar('MACHINE', d, 1)
43 if machine == "cm-x270":
44 deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
45 kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
46 img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
47
48 fo = open(img_file, 'wb')
49
50 image_data = open(kernel_file, 'rb').read()
51
52 # first write size into first 4 bytes
53 size_s = struct.pack('i', len(image_data))
54
55 # truncate size if we are running on a 64-bit host
56 size_s = size_s[:4]
57
58 fo.write(size_s)
59 fo.write(image_data)
60 fo.close()
61
62 os.chdir(deploy_dir)
63 link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
64 img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
65 try:
66 os.unlink(link_file)
67 except:
68 pass
69 os.symlink(img_file, link_file)
70}
71
72addtask compulab_image after do_deploy before do_package
73
74do_kernel_image() {
75
76 if [ "${MACHINE}" = "em-x270" ]
77 then
78 mkdir -p ${WORKDIR}/t
79 install -m 0644 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_SYMLINK_NAME}.bin ${WORKDIR}/t/uImage
80 mkfs.jffs2 --eraseblock=0x20000 --pad --no-cleanmarkers --faketime --root=${WORKDIR}/t --output=${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.jffs2
81 cd ${DEPLOY_DIR_IMAGE} && ln -sf ${KERNEL_IMAGE_BASE_NAME}.jffs2 uImage-em-x270.jffs2
82 fi
83}
84addtask kernel_image after do_deploy