summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
new file mode 100644
index 0000000000..81816b15d2
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -0,0 +1,38 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4KBRANCH = "standard/base"
5KBRANCH_qemux86 = "standard/common-pc/base"
6KBRANCH_qemux86-64 = "standard/common-pc-64/base"
7KBRANCH_qemuppc = "standard/qemuppc"
8KBRANCH_qemumips = "standard/mti-malta32"
9KBRANCH_qemumips64 = "standard/mti-malta64"
10KBRANCH_qemumips64el = "standard/mti-malta64"
11KBRANCH_qemuarm = "standard/arm-versatile-926ejs"
12
13SRCREV_machine_qemuarm ?= "bc7dd2ebe7f5443fb9d89d46106053cfc69b5d7f"
14SRCREV_machine_qemumips ?= "5a2ad0078de3d24a6e8e3f3c9a7426a08a86717d"
15SRCREV_machine_qemuppc ?= "f92ab2a332627c0213ecfdfc873d470be008f86b"
16SRCREV_machine_qemux86 ?= "780ab7e11f03931295e8f0e29707f2abb688e9ad"
17SRCREV_machine_qemux86-64 ?= "780ab7e11f03931295e8f0e29707f2abb688e9ad"
18SRCREV_machine ?= "780ab7e11f03931295e8f0e29707f2abb688e9ad"
19SRCREV_meta ?= "3fd089debe624c642d7b4d9363f853021d1675b2"
20
21SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
22
23LINUX_VERSION ?= "3.4.1"
24
25PR = "r0"
26PV = "${LINUX_VERSION}+git${SRCPV}"
27
28KMETA = "meta"
29
30COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
31
32# Functionality flags
33KERNEL_REVISION_CHECKING=""
34KERNEL_FEATURES="features/netfilter"
35KERNEL_FEATURES_append_qemux86=" cfg/sound"
36KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
37
38require recipes-kernel/linux/linux-tools.inc