summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
new file mode 100644
index 0000000000..1d52bfeeba
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
@@ -0,0 +1,32 @@
1KBRANCH ?= "v5.8/standard/tiny/base"
2KBRANCH_qemuarm ?= "v5.8/standard/tiny/arm-versatile-926ejs"
3
4LINUX_KERNEL_TYPE = "tiny"
5KCONFIG_MODE = "--allnoconfig"
6
7require recipes-kernel/linux/linux-yocto.inc
8
9LINUX_VERSION ?= "5.8"
10LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
11
12DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
13DEPENDS += "openssl-native util-linux-native"
14
15KMETA = "kernel-meta"
16KCONF_BSP_AUDIT_LEVEL = "2"
17
18SRCREV_machine_qemuarm ?= "8c6b76ac37ee5c0f09ffff816a6519f3f8ea6582"
19SRCREV_machine ?= "581a55ca5571041bc5885febe8415c5751c489d9"
20SRCREV_meta ?= "4c62a6f4fa227abacf87f1593faa1ac6e6616156"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.8;destsuffix=${KMETA}"
26
27COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
28
29# Functionality flags
30KERNEL_FEATURES = ""
31
32KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"