summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
new file mode 100644
index 0000000000..1f0b35ec25
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
@@ -0,0 +1,29 @@
1KBRANCH ?= "v4.18/standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "4.18.3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
9
10DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
11DEPENDS += "openssl-native util-linux-native"
12
13KMETA = "kernel-meta"
14KCONF_BSP_AUDIT_LEVEL = "2"
15
16SRCREV_machine ?= "eba03655e8e436ef6090100423bcea43e4911478"
17SRCREV_meta ?= "1f78e20cc98dd46637c0beb6007214fb3650992c"
18
19PV = "${LINUX_VERSION}+git${SRCPV}"
20
21SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
22 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"
23
24COMPATIBLE_MACHINE = "qemux86|qemux86-64"
25
26# Functionality flags
27KERNEL_FEATURES = ""
28
29KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"