summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
new file mode 100644
index 0000000000..ff395e0ad7
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
@@ -0,0 +1,25 @@
1KBRANCH ?= "standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "4.12.7"
8
9KMETA = "kernel-meta"
10KCONF_BSP_AUDIT_LEVEL = "2"
11
12SRCREV_machine ?= "d09f2ce584d60ecb7890550c22a80c48b83c2e19"
13SRCREV_meta ?= "edb42d48052dee4dbc3ed9d5e1e39c1375e85fe0"
14
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
19
20COMPATIBLE_MACHINE = "(qemux86$)"
21
22# Functionality flags
23KERNEL_FEATURES = ""
24
25KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"