summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
new file mode 100644
index 0000000000..d2c8bf7ed6
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
@@ -0,0 +1,25 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4# We need lzma (as CONFIG_KERNEL_LZMA=y)
5DEPENDS += "xz-native"
6
7KMACHINE = "common-pc"
8KBRANCH = "standard/tiny"
9LINUX_KERNEL_TYPE = "tiny"
10KCONFIG_MODE = "--allnoconfig"
11
12LINUX_VERSION ?= "3.2.11"
13
14SRCREV_machine ?= "ec236058dc254183dbfb3744bf21f110c37af30b"
15SRCREV_meta ?= "59f350ec3794e19fa806c1b73749d851f8ebf364"
16
17PR = "r0"
18PV = "${LINUX_VERSION}+git${SRCPV}"
19
20SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
21
22COMPATIBLE_MACHINE = "(qemux86)"
23
24# Functionality flags
25KERNEL_FEATURES = ""