summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-stable_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-stable_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-stable_git.bb b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
index dd4d176ac5..85b67f4ddc 100644
--- a/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
@@ -12,8 +12,9 @@ KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
12KMACHINE_beagleboard = "beagleboard" 12KMACHINE_beagleboard = "beagleboard"
13 13
14LINUX_VERSION ?= "2.6.34" 14LINUX_VERSION ?= "2.6.34"
15LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}" 15LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
16PR = "r0" 16
17PR = "r1"
17PV = "${LINUX_VERSION}+git${SRCPV}" 18PV = "${LINUX_VERSION}+git${SRCPV}"
18SRCREV_FORMAT = "meta_machine" 19SRCREV_FORMAT = "meta_machine"
19 20
@@ -21,11 +22,14 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|route
21 22
22# this performs a fixup on the SRCREV for new/undefined BSPs 23# this performs a fixup on the SRCREV for new/undefined BSPs
23python __anonymous () { 24python __anonymous () {
24 import bb, re 25 import bb, re, string
25 26
26 rev = bb.data.getVar("SRCREV_machine", d, 1) 27 rev = bb.data.getVar("SRCREV_machine", d, 1)
27 if rev == "standard": 28 if rev == "standard":
28 bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d) 29 bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d)
30
31 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
32 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
29} 33}
30 34
31SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \ 35SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \