summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-stable_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-stable_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-stable_git.bb b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
new file mode 100644
index 0000000000..8ecd86fa9f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-stable_git.bb
@@ -0,0 +1,41 @@
1inherit kernel
2require linux-yocto.inc
3
4KMACHINE_qemux86 = "common_pc/base"
5KMACHINE_qemux86-64 = "common_pc_64"
6KMACHINE_qemuppc = "qemu_ppc32"
7KMACHINE_qemumips = "mti_malta32_be"
8KMACHINE_qemuarm = "arm_versatile_926ejs"
9KMACHINE_atom-pc = "atom-pc"
10KMACHINE_routerstationpro = "routerstationpro"
11KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
12KMACHINE_beagleboard = "beagleboard"
13
14LINUX_VERSION ?= "2.6.34"
15LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
16PR = "r0"
17PV = "${LINUX_VERSION}+git${SRCPV}"
18SRCREV_FORMAT = "meta_machine"
19
20# this performs a fixup on the SRCREV for new/undefined BSPs
21python __anonymous () {
22 import bb, re
23
24 rev = bb.data.getVar("SRCREV_machine", d, 1)
25 if rev == "standard":
26 bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d)
27}
28
29SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
30 git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
31
32
33# Functionality flags
34KERNEL_REVISION_CHECKING ?= "t"
35KERNEL_FEATURES=features/netfilter
36
37# extra tasks
38addtask kernel_link_vmlinux after do_compile before do_install
39addtask validate_branches before do_patch after do_kernel_checkout
40
41require linux-tools.inc