summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb
deleted file mode 100644
index 75aa21055f..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1KBRANCH ?= "v4.15/standard/preempt-rt/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of
8# core-image-rt-sdk, core-image-rt.
9python () {
10 if d.getVar("KERNEL_PACKAGE_NAME") == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
11 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12}
13
14SRCREV_machine ?= "3373c0cf71f2812eeb9694839456df6f67fd32ac"
15SRCREV_meta ?= "4f95b5be8ca7af984b4abee7f6f9eeccd136a5cb"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.15;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.15.18"
21
22DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
23DEPENDS += "openssl-native util-linux-native"
24
25PV = "${LINUX_VERSION}+git${SRCPV}"
26
27KMETA = "kernel-meta"
28KCONF_BSP_AUDIT_LEVEL = "2"
29
30LINUX_KERNEL_TYPE = "preempt-rt"
31
32COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuppc|qemumips)"
33
34KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
35
36# Functionality flags
37KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
38KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
39KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
40KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
41KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"