summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb b/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
new file mode 100644
index 0000000000..0ca53ae436
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
@@ -0,0 +1,44 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common_pc"
6KMACHINE_qemux86-64 = "common_pc_64"
7
8LINUX_VERSION ?= "2.6.34"
9LINUX_KERNEL_TYPE = "preempt_rt"
10LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
11
12KMETA = wrs_meta
13KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
14
15SRCREV_machine_qemux86 = "439602eb6acd53d9beb8493710310214fc7bd749"
16SRCREV_machine_qemux86-64 = "3c84c45ad3c3592f9c7ff4076de9bee417cd322e"
17SRCREV_machine = "439602eb6acd53d9beb8493710310214fc7bd749"
18SRCREV_meta = "e1f85a470934a0cf6abde5d95533e74501822c6b"
19
20PR = "r2"
21PV = "${LINUX_VERSION}+git${SRCPV}"
22SRCREV_FORMAT = "meta_machine"
23
24COMPATIBLE_MACHINE = "(qemux86|qemux86-64)"
25
26# this performs a fixup on the SRCREV for new/undefined BSPs
27python __anonymous () {
28 import bb, re, string
29
30 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
31 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
32}
33
34SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
35
36# Functionality flags
37KERNEL_REVISION_CHECKING ?= "t"
38KERNEL_FEATURES=features/netfilter
39
40# extra tasks
41addtask kernel_link_vmlinux after do_compile before do_install
42addtask validate_branches before do_patch after do_kernel_checkout
43
44require recipes-kernel/linux/linux-tools.inc