summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-dev.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-dev.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb29
1 files changed, 11 insertions, 18 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 5e097203e2..9b49eee876 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -11,37 +11,30 @@
11inherit kernel 11inherit kernel
12require recipes-kernel/linux/linux-yocto.inc 12require recipes-kernel/linux/linux-yocto.inc
13 13
14USE_MACHINE_AUTOREV ?= "1"
15USE_META_AUTOREV ?= "1"
16
17# provide this .inc to set specific revisions 14# provide this .inc to set specific revisions
18include recipes-kernel/linux/linux-yocto-dev-revisions.inc 15include recipes-kernel/linux/linux-yocto-dev-revisions.inc
19 16
17# Skip processing of this recipe if it is not explicitly specified as the
18# PREFERRED_PROVIDER for virtual/kernel. This avoids network access required
19# by the use of AUTOREV SRCREVs, which are the default for this recipe.
20python () {
21 if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
22 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
23}
24
20KBRANCH = "standard/base" 25KBRANCH = "standard/base"
21KBRANCH_DEFAULT = "${KBRANCH}" 26KBRANCH_DEFAULT = "${KBRANCH}"
22KMETA = "meta" 27KMETA = "meta"
23 28
24SRC_URI = "git://git.pokylinux.org/linux-yocto-dev.git;nocheckout=1;branch=${KBRANCH},${KMETA};name=machine,meta" 29SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
25 30
26# Set default SRCREVs. Both the machine and meta SRCREVs are statically set 31# Set default SRCREVs. Both the machine and meta SRCREVs are statically set
27# to the korg v3.7 tag, and hence prevent network access during parsing. If 32# to the korg v3.7 tag, and hence prevent network access during parsing. If
28# linux-yocto-dev is the preferred provider, they will be overridden to 33# linux-yocto-dev is the preferred provider, they will be overridden to
29# AUTOREV in following anonymous python routine and resolved when the 34# AUTOREV in following anonymous python routine and resolved when the
30# variables are finalized. 35# variables are finalized.
31SRCREV_machine ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e" 36SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
32SRCREV_meta ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e" 37SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
33
34python () {
35 if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
36 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
37 else:
38 # if the revisions have been changed from the defaults above we leave them
39 # alone. But if the defaults are left, we change to AUTOREV.
40 if d.getVar("USE_MACHINE_AUTOREV", True) == "1":
41 d.setVar("SRCREV_machine", "${AUTOREV}")
42 if d.getVar("USE_META_AUTOREV", True) == "1":
43 d.setVar("SRCREV_meta", "${AUTOREV}")
44}
45 38
46LINUX_VERSION ?= "3.14+" 39LINUX_VERSION ?= "3.14+"
47LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}" 40LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"