summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-rp_2.6.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-rp_2.6.26.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-rp_2.6.26.bb196
1 files changed, 196 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-rp_2.6.26.bb b/meta/recipes-kernel/linux/linux-rp_2.6.26.bb
new file mode 100644
index 0000000000..67d674b7be
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-rp_2.6.26.bb
@@ -0,0 +1,196 @@
1require linux-rp.inc
2
3PR = "r11"
4
5DEFAULT_PREFERENCE = "-1"
6DEFAULT_PREFERENCE_qemuarm = "1"
7DEFAULT_PREFERENCE_qemuarmv6 = "1"
8DEFAULT_PREFERENCE_qemuarmv7 = "1"
9DEFAULT_PREFERENCE_qemux86 = "1"
10DEFAULT_PREFERENCE_spitz = "1"
11DEFAULT_PREFERENCE_c7x0 = "1"
12
13# Handy URLs
14# git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
15# ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
16# ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
17# ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
18# ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
19# ${KERNELORG_MIRROR}/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
20# ${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
21
22# Patches submitted upstream are towards top of this list
23# Hacks should clearly named and at the bottom
24SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
25 ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
26 ${RPSRC}/hx2750_base-r34.patch;patch=1 \
27 ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
28 ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1 \
29 ${RPSRC}/pxa_keys-r9.patch;patch=1 \
30 ${RPSRC}/tsc2101-r19.patch;patch=1 \
31 ${RPSRC}/hx2750_test1-r8.patch;patch=1 \
32 ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
33 ${RPSRC}/pm_changes-r1.patch;patch=1 \
34 ${RPSRC}/locomo_kbd_tweak-r2.patch;patch=1 \
35# ${RPSRC}/pxa27x_overlay-r8.patch;patch=1 \
36 ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
37 ${RPSRC}/w100_extmem-r1.patch;patch=1 \
38 ${RPSRC}/poodle_pm-r6.patch;patch=1 \
39 ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
40 ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
41 ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
42 ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
43 file://hostap-monitor-mode.patch;patch=1;status=unmergable \
44 file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
45 ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
46 ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
47 ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
48 ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
49 file://sharpsl-rc-r1.patch;patch=1 \
50 file://spitz_h_rewrite.patch;patch=1 \
51 file://pxa-serial-hack.patch;patch=1;status=hack \
52 file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
53 file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
54 file://htcuni.patch;patch=1 \
55 file://versatile-armv6.patch;patch=1 \
56 file://cpufreq-fix.patch;patch=1 \
57 file://zaurus-i2c-init.patch;patch=1 \
58 file://fixes.patch;patch=1 \
59 file://defconfig-c7x0 \
60 file://defconfig-hx2000 \
61 file://defconfig-akita \
62 file://defconfig-spitz \
63 file://defconfig-qemuarm \
64 file://defconfig-qemuarmv6 \
65 file://defconfig-qemuarmv7 \
66 file://defconfig-qemux86 \
67 file://defconfig-bootcdx86 \
68 file://defconfig-htcuniversal \
69 file://defconfig-zylonite"
70# Disabled until the patchset is updated:
71# file://defconfig-tosa
72# file://defconfig-collie
73# file://defconfig-poodle
74
75
76# FIXMEs before made default
77# ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
78
79
80# Add this to enable pm debug code (useful with a serial lead)
81# ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
82
83# Disabled until I find the reason this gives issues with cdc_subset
84# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
85
86
87SRC_URI_append_collie = "\
88 ${TKSRC}/mtd-sharp-flash-hack-r4.patch;patch=1 \
89 ${TKSRC}/mcp-sa11x0-r0.patch;patch=1 \
90 ${TKSRC}/locomo-r1.patch;patch=1 \
91 ${TKSRC}/collie-kexec-r1.patch;patch=1 \
92 ${TKSRC}/sharpsl_pm-4.patch;patch=1 \
93 ${TKSRC}/collie_pm-3.patch;patch=1 \
94 ${TKSRC}/ucb1x00_suspend.patch;patch=1 \
95 ${TKSRC}/collie-ts.patch;patch=1 \
96 ${TKSRC}/pcmcia_suspend.patch;patch=1 \
97 ${TKSRC}/locomo_spi-6.patch;patch=1 \
98 ${TKSRC}/config.patch;patch=1 \
99 ${TKSRC}/locomokeyb-2.patch;patch=1 \
100 ${TKSRC}/mmc-spi.patch;patch=1 \
101 ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
102 ${TKSRC}/sa1100_spinlock.patch;patch=1 \
103 ${TKSRC}/sa1100-dma.patch;patch=1 \
104 ${TKSRC}/sa1100_udc_g_ether-2.patch;patch=1 \
105"
106
107SRC_URI_append_poodle = "\
108 ${RPSRC}/poodle_serial_vcc-r0.patch;patch=1 \
109 file://poodle_ts.patch;patch=1 \
110 file://pxafb.patch;patch=1 \
111"
112
113SRC_URI_append_tosa = "\
114 file://tosa/0001-Allow-runtime-registration-of-regions-of-memory-that.patch;patch=1 \
115 file://tosa/0002-Modify-dma_alloc_coherent-on-ARM-so-that-it-supports.patch;patch=1 \
116 file://tosa/0003-Core-MFD-support.patch;patch=1 \
117 file://tosa/0004-Add-support-for-tc6393xb-MFD-core.patch;patch=1 \
118 file://tosa/0005-Add-support-for-tc6387xb-MFD-core.patch;patch=1 \
119 file://tosa/0006-Add-support-for-t7l66xb-MFD-core.patch;patch=1 \
120 file://tosa/0007-Common-headers-for-TMIO-MFD-subdevices.patch;patch=1 \
121 file://tosa/0008-Nand-driver-for-TMIO-devices.patch;patch=1 \
122 file://tosa/0009-FB-driver-for-TMIO-devices.patch;patch=1 \
123 file://tosa/0010-OHCI-driver-for-TMIO-devices.patch;patch=1 \
124 file://tosa/0011-MMC-driver-for-TMIO-devices.patch;patch=1 \
125 file://tosa/0012-Tosa-keyboard-support.patch;patch=1 \
126 file://tosa/0013-USB-gadget-pxa2xx_udc-supports-inverted-vbus.patch;patch=1 \
127 file://tosa/0014-tosa_udc_use_gpio_vbus.patch.patch;patch=1 \
128 file://tosa/0015-sharpsl-export-params.patch;patch=1 \
129 file://tosa/0016-This-patch-fixes-the-pxa25x-clocks-definitions-to-ad.patch;patch=1 \
130 file://tosa/0017-Convert-pxa2xx-UDC-to-use-debugfs.patch;patch=1 \
131 file://tosa/0018-Fix-the-pxa2xx_udc-to-balance-calls-to-clk_enable-cl.patch;patch=1 \
132 file://tosa/0026-I-don-t-think-we-should-check-for-IRQs-when-determin.patch;patch=1 \
133 file://tosa/0027-Add-LiMn-one-of-the-most-common-for-small-non-recha.patch;patch=1 \
134 file://tosa/0028-Add-suspend-resume-wakeup-support-for-pda_power.patch;patch=1 \
135 file://tosa/0029-Support-using-VOLTAGE_-properties-for-apm-calculati.patch;patch=1 \
136 file://tosa/0030-Core-driver-for-WM97xx-touchscreens.patch;patch=1 \
137 file://tosa/0031-Add-chip-driver-for-WM9705-touchscreen.patch;patch=1 \
138 file://tosa/0032-Add-chip-driver-for-WM9712-touchscreen.patch;patch=1 \
139 file://tosa/0033-Add-chip-driver-for-WM9713-touchscreen.patch;patch=1 \
140 file://tosa/0034-Driver-for-WM97xx-touchscreens-in-streaming-mode-on.patch;patch=1 \
141 file://tosa/0035-Build-system-and-MAINTAINERS-entry-for-WM97xx-touchs.patch;patch=1 \
142 file://tosa/0036-Set-id-to-1-for-wm97xx-subdevices.patch;patch=1 \
143 file://tosa/0037-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch;patch=1 \
144 file://tosa/0038-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch;patch=1 \
145 file://tosa/0044-fix-tmio_mmc-debug-compilation.patch;patch=1 \
146 file://tosa/0045-Update-tmio_ohci.patch;patch=1 \
147 file://tosa/0046-patch-tc6393xb-cleanup.patch;patch=1 \
148 file://tosa/0047-tc6393xb-use-bitmasks-instead-of-bit-field-structs.patch;patch=1 \
149 file://tosa/0048-tc6393xb-GPIO-support.patch;patch=1 \
150 file://tosa/0049-platform-support-for-TMIO-on-tosa.patch;patch=1 \
151 file://tosa/0050-tosa-update-for-tc6393xb-gpio.patch;patch=1 \
152 file://tosa/0051-fix-sound-soc-pxa-tosa.c-to-new-gpio-api.patch;patch=1 \
153 file://tosa/0052-tosa-platform-backlight-support.patch;patch=1 \
154 file://tosa/0053-sound-soc-codecs-wm9712.c-28.patch;patch=1 \
155 file://tosa/0054-sound-soc-codecs-wm9712.c-2.patch;patch=1 \
156 file://tosa/0055-Add-GPIO_POWERON-to-the-list-of-devices-that-we-supp.patch;patch=1 \
157 file://tosa/0058-Fix-tosakbd-suspend.patch;patch=1 \
158 file://tosa/0059-patch-tosa-wakeup-test.patch;patch=1 \
159 file://tosa/0060-Add-support-for-power_supply-on-tosa.patch;patch=1 \
160 file://tosa/0061-tosa-bat-unify.patch;patch=1 \
161 file://tosa/0062-tosa-bat-fix-charging.patch;patch=1 \
162 file://tosa/0063-patch-tosa-bat-jacket-detect.patch;patch=1 \
163 file://tosa/0064-Export-modes-via-sysfs.patch;patch=1 \
164 file://tosa/0065-wm97xx-core-fixes.patch;patch=1 \
165 file://tosa/0066-tmiofb_probe-should-be-__devinit.patch;patch=1 \
166 file://tosa/0067-modeswitching.patch;patch=1 \
167 file://tosa/0068-Preliminary-tosa-denoiser.patch;patch=1 \
168 file://tosa/0019-pxa-remove-periodic-mode-emulation-support.patch;patch=1 \
169 file://tosa/0020-Provide-dew-device-clock-backports-from-2.6.24-git.patch;patch=1 \
170 file://tosa/0021-Add-an-empty-drivers-gpio-directory-for-gpiolib-infr.patch;patch=1 \
171 file://tosa/0022-Provide-new-implementation-infrastructure-that-platf.patch;patch=1 \
172 file://tosa/0023-This-adds-gpiolib-support-for-the-PXA-architecture.patch;patch=1 \
173 file://tosa/0024-Update-Documentation-gpio.txt-primarily-to-include.patch;patch=1 \
174 file://tosa/0025-Signed-off-by-Dmitry-Baryshkov-dbaryshkov-gmail.co.patch;patch=1 \
175 file://tosa/0039-Add-generic-framework-for-managing-clocks.patch;patch=1 \
176 file://tosa/0040-Clocklib-debugfs-support.patch;patch=1 \
177 file://tosa/0041-From-80a359e60c2aec59ccf4fca0a7fd20495f82b1d2-Mon-Se.patch;patch=1 \
178 file://tosa/0042-Use-correct-clock-for-IrDA-on-pxa.patch;patch=1 \
179 file://tosa/0043-Use-clocklib-for-sa1100-sub-arch.patch;patch=1 \
180 file://tosa/0056-Support-resetting-by-asserting-GPIO-pin.patch;patch=1 \
181 file://tosa/0057-Clean-up-tosa-resetting.patch;patch=1 \
182 "
183
184SRC_URI_append_htcuniversal ="\
185 file://htcuni-acx.patch;patch=1;status=external \
186 "
187
188SRC_URI_append_zylonite ="\
189 file://pxa_fb_overlay.patch;patch=1 \
190 file://zylonite-boot.patch;patch=1 \
191 file://zylonite_mtd-r0.patch;patch=1 \
192 file://zylonite_touch-r0.patch;patch=1 \
193 file://zylonite_keypad-r0.patch;patch=1 \
194 "
195
196S = "${WORKDIR}/linux-2.6.26"