summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-omap2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-omap2_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-omap2_git.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-omap2_git.bb b/meta/recipes-kernel/linux/linux-omap2_git.bb
new file mode 100644
index 0000000000..4d4692dbb2
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-omap2_git.bb
@@ -0,0 +1,70 @@
1require linux-omap2.inc
2
3FILESPATH = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-omap2-git/${MACHINE}:${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-omap2-git"
4
5SRCREV = "d3b3ae0fe6c71641da19c8de466ec366d39847e3"
6
7PV = "2.6.26"
8#PV = "2.6.26+2.6.27-rc1+${PR}+git${SRCREV}"
9PR = "r53"
10
11SRC_URI = "git://source.mvista.com/git/linux-omap-2.6.git;protocol=git \
12 file://fixes.patch;patch=1 \
13 file://defconfig"
14
15SRC_URI_append_beagleboard = " file://no-harry-potter.diff;patch=1 \
16 file://0001-ASoC-OMAP-Add-basic-support-for-OMAP34xx-in-McBSP.patch;patch=1 \
17 file://flash.patch;patch=1 \
18 file://0001-omap3-cpuidle.patch;patch=1 \
19 file://0002-omap3-cpuidle.patch;patch=1 \
20 file://timer-suppression.patch;patch=1 \
21 file://soc.patch;patch=1 \
22 file://16bpp.patch;patch=1 \
23 file://no-empty-flash-warnings.patch;patch=1 \
24 file://logo_linux_clut224.ppm \
25 file://oprofile-0.9.3.armv7.diff;patch=1 \
26 file://01-fix-timing-print.diff;patch=1 \
27 file://03-enable-overlay-opt.diff;patch=1 \
28 file://04-use-pcd.diff;patch=1 \
29 file://05-fix-display-panning.diff;patch=1 \
30 file://06-ensure-fclk.diff;patch=1 \
31 file://07-set-burst-size.diff;patch=1 \
32 file://cache-display-fix.patch;patch=1 \
33 file://i2c-omap-race-fix.diff;patch=1 \
34 file://TWL4030-01.patch;patch=1 \
35 file://TWL4030-02.patch;patch=1 \
36 file://TWL4030-03.patch;patch=1 \
37 file://TWL4030-04.patch;patch=1 \
38 file://TWL4030-05.patch;patch=1 \
39 file://TWL4030-06.patch;patch=1 \
40 file://TWL4030-07.patch;patch=1 \
41 file://TWL4030-08.patch;patch=1 \
42 file://TWL4030-09.patch;patch=1 \
43 file://mru-clocks1.diff;patch=1 \
44 file://mru-clocks2.diff;patch=1 \
45 file://mru-clocks3.diff;patch=1 \
46 file://4bitmmc.diff;patch=1 \
47 file://400khz-i2c.diff;patch=1 \
48 file://no-cortex-deadlock.patch;patch=1 \
49 file://01-gptimer_clear_isrs_on_init;patch=1 \
50 file://02-gptimer_use_match_for_tick;patch=1 \
51 file://03-gptimer_match_plus_ovf;patch=1 \
52 file://04-gptimer_add_debug_to_sysrq_q;patch=1 \
53 file://read_die_ids.patch;patch=1 \
54"
55
56SRC_URI_append_omap3evm = " file://no-harry-potter.diff;patch=1 \
57 file://0001-ASoC-OMAP-Add-basic-support-for-OMAP34xx-in-McBSP.patch;patch=1 \
58 file://0001-omap3-cpuidle.patch;patch=1 \
59 file://0002-omap3-cpuidle.patch;patch=1 \
60 file://timer-suppression.patch;patch=1 \
61 file://soc.patch;patch=1 \
62 file://no-empty-flash-warnings.patch;patch=1 \
63 file://touchscreen.patch;patch=1 \
64"
65
66
67COMPATIBLE_MACHINE = "omap2430sdp|omap2420h4|beagleboard|omap3evm"
68
69
70S = "${WORKDIR}/git"