summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/kernel-devsrc.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/kernel-devsrc.bb')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 8fc0ffdbb3..cf2b476051 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -150,6 +150,13 @@ do_install() {
150 cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/ 150 cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/
151 fi 151 fi
152 152
153 if [ "${ARCH}" = "powerpc" ]; then
154 # 5.0 needs these files, but don't error if they aren't present in the source
155 cp -a --parents arch/${ARCH}/kernel/syscalls/syscall.tbl $kerneldir/build/ 2>/dev/null || :
156 cp -a --parents arch/${ARCH}/kernel/syscalls/syscalltbl.sh $kerneldir/build/ 2>/dev/null || :
157 cp -a --parents arch/${ARCH}/kernel/syscalls/syscallhdr.sh $kerneldir/build/ 2>/dev/null || :
158 fi
159
153 # include the machine specific headers for ARM variants, if available. 160 # include the machine specific headers for ARM variants, if available.
154 if [ "${ARCH}" = "arm" ]; then 161 if [ "${ARCH}" = "arm" ]; then
155 cp -a --parents arch/${ARCH}/mach-*/include $kerneldir/build/ 162 cp -a --parents arch/${ARCH}/mach-*/include $kerneldir/build/
@@ -214,6 +221,9 @@ do_install() {
214 cp -a --parents kernel/time/timeconst.bc $kerneldir/build 221 cp -a --parents kernel/time/timeconst.bc $kerneldir/build
215 cp -a --parents kernel/bounds.c $kerneldir/build 222 cp -a --parents kernel/bounds.c $kerneldir/build
216 cp -a --parents Kbuild $kerneldir/build 223 cp -a --parents Kbuild $kerneldir/build
224 cp -a --parents arch/mips/kernel/syscalls/*.sh $kerneldir/build
225 cp -a --parents arch/mips/kernel/syscalls/*.tbl $kerneldir/build
226 cp -a --parents arch/mips/tools/elf-entry.c $kerneldir/build 2>/dev/null || :
217 fi 227 fi
218 228
219 # required to build scripts/selinux/genheaders/genheaders 229 # required to build scripts/selinux/genheaders/genheaders