summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-wrs_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux-libc-headers/linux-libc-headers-wrs_git.bb')
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers-wrs_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-wrs_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-wrs_git.bb
new file mode 100644
index 0000000000..ab25e500ba
--- /dev/null
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-wrs_git.bb
@@ -0,0 +1,51 @@
1require linux-libc-headers.inc
2
3INHIBIT_DEFAULT_DEPS = "1"
4DEPENDS += "unifdef-native"
5PROVIDES = "linux-libc-headers"
6PV = "2.6.34+git-${SRCPV}"
7PR = "r0"
8
9SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;fullclone=1"
10
11S = "${WORKDIR}/linux"
12
13set_arch() {
14 case ${TARGET_ARCH} in
15 arm*) ARCH=arm ;;
16 i*86*) ARCH=i386 ;;
17 ia64*) ARCH=ia64 ;;
18 mips*) ARCH=mips ;;
19 powerpc*) ARCH=powerpc ;;
20 x86_64*) ARCH=x86_64 ;;
21 esac
22}
23
24do_configure() {
25 set_arch
26 oe_runmake allnoconfig ARCH=$ARCH
27}
28
29do_wrlinux_checkout() {
30 if [ -d ${WORKDIR}/.git/refs/remotes/origin ]; then
31 rm -rf ${S}
32 mkdir ${S}
33 mv ${WORKDIR}/.git ${S}
34 mv ${S}/.git/refs/remotes/origin/* ${S}/.git/refs/heads
35 rmdir ${S}/.git/refs/remotes/origin
36 fi
37 cd ${S}
38 git checkout -f standard
39}
40
41addtask wrlinux_checkout before do_patch after do_unpack
42
43do_compile () {
44}
45
46do_install() {
47 set_arch
48 oe_runmake headers_install_all INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
49}
50
51BBCLASSEXTEND = "nativesdk"