summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb')
-rw-r--r--meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb b/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb
new file mode 100644
index 0000000000..f9a3811669
--- /dev/null
+++ b/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.3.bb
@@ -0,0 +1,27 @@
1# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "API to access the kernel tracefs directory"
5HOMEPAGE = "https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git/"
6LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
8 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
9SECTION = "libs"
10
11SRCREV = "dd148189b74da3e2f45c7e536319fec97cb71213"
12SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git;branch=${BPN};protocol=https \
13 file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch"
14
15S = "${WORKDIR}/git"
16
17export EXTRA_CFLAGS = "${CFLAGS}"
18
19inherit pkgconfig
20
21do_install() {
22 oe_runmake install DESTDIR=${D} pkgconfig_dir=${libdir}/pkgconfig
23}
24
25PACKAGES += "${PN}-plugins"
26
27FILES:${PN}-plugins += "${libdir}/traceevent/plugins"