summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index d4c21a4387..08dd81569c 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -34,6 +34,10 @@ do_install_append () {
34 # install depmod.d file for search/ dir 34 # install depmod.d file for search/ dir
35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf" 35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
36 36
37 if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
38 find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
39 find testsuite -name *.ko -exec rm -f {} \;
40 fi
37} 41}
38 42
39do_compile_prepend() { 43do_compile_prepend() {
@@ -44,7 +48,10 @@ do_compile_ptest () {
44 oe_runmake buildtest-TESTS rootfs 48 oe_runmake buildtest-TESTS rootfs
45} 49}
46 50
47INHIBIT_PACKAGE_STRIP = "${@bb.utils.contains("DISTRO_FEATURES", "ptest", "1", "0", d)}" 51do_install_ptest () {
52 install testmodule.tar ${D}${PTEST_PATH}
53}
54
48INSANE_SKIP_${PN}-ptest = "arch" 55INSANE_SKIP_${PN}-ptest = "arch"
49 56
50inherit update-alternatives 57inherit update-alternatives