summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index 08dd81569c..ba4d85eda4 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -33,27 +33,12 @@ do_install_append () {
33 33
34 # install depmod.d file for search/ dir 34 # install depmod.d file for search/ dir
35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf" 35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
36
37 if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
38 find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
39 find testsuite -name *.ko -exec rm -f {} \;
40 fi
41} 36}
42 37
43do_compile_prepend() { 38do_compile_prepend() {
44 sed -i 's/ac_pwd=/#ac_pwd=/' config.status ; sed -i "/#ac_pwd=/a\ac_pwd='.'" config.status 39 sed -i 's/ac_pwd=/#ac_pwd=/' config.status ; sed -i "/#ac_pwd=/a\ac_pwd='.'" config.status
45} 40}
46 41
47do_compile_ptest () {
48 oe_runmake buildtest-TESTS rootfs
49}
50
51do_install_ptest () {
52 install testmodule.tar ${D}${PTEST_PATH}
53}
54
55INSANE_SKIP_${PN}-ptest = "arch"
56
57inherit update-alternatives 42inherit update-alternatives
58 43
59ALTERNATIVE_PRIORITY = "60" 44ALTERNATIVE_PRIORITY = "60"