summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/kern-tools/kern-tools-native_git.bb')
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb16
1 files changed, 4 insertions, 12 deletions
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index ef078cef2a..fb66211e7d 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,8 +4,8 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
4 4
5DEPENDS = "git-native guilt-native" 5DEPENDS = "git-native guilt-native"
6 6
7SRCREV = "364437739c45a5e771d1f7b3ac73c35f1328fd97" 7SRCREV = "eb3ed64cea80d23ffb28dfeaeb02cdfe3fb29340"
8PR = r11 8PR = r12
9PV = "0.1+git${SRCPV}" 9PV = "0.1+git${SRCPV}"
10 10
11inherit native 11inherit native
@@ -13,19 +13,11 @@ inherit native
13SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git;protocol=git" 13SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git;protocol=git"
14S = "${WORKDIR}" 14S = "${WORKDIR}"
15 15
16kern_tools_LIST = kgit kgit-init kgit-meta \
17 kgit-checkpoint kgit-clean \
18 generate_cfg kconf_check configme \
19 createme updateme patchme get_defconfig scc \
20 pre_config merge_config.sh
21
22do_compile() { 16do_compile() {
23 : 17 :
24} 18}
25 19
26do_install() { 20do_install() {
27 install -d ${D}${bindir} 21 cd ${S}/git
28 for s in ${kern_tools_LIST}; do 22 make DESTDIR=${D}${bindir} install
29 install -m 0755 ${S}/git/tools/$s ${D}${bindir}
30 done
31} 23}