summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/dtc/dtc_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/dtc/dtc_1.7.0.bb')
-rw-r--r--meta/recipes-kernel/dtc/dtc_1.7.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-kernel/dtc/dtc_1.7.0.bb b/meta/recipes-kernel/dtc/dtc_1.7.0.bb
new file mode 100644
index 0000000000..0fc3eca002
--- /dev/null
+++ b/meta/recipes-kernel/dtc/dtc_1.7.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Device Tree Compiler"
2HOMEPAGE = "https://devicetree.org/"
3DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
4SECTION = "bootloader"
5LICENSE = "GPL-2.0-only | BSD-2-Clause"
6
7LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://libfdt/libfdt.h;beginline=4;endline=7;md5=05bb357cfb75cae7d2b01d2ee8d76407"
9
10SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=main"
11SRCREV = "039a99414e778332d8f9c04cbd3072e1dcc62798"
12
13UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
14
15S = "${WORKDIR}/git"
16
17inherit meson pkgconfig
18
19EXTRA_OEMESON = "-Dpython=disabled -Dvalgrind=disabled"
20
21PACKAGECONFIG ??= "tools"
22PACKAGECONFIG[tools] = "-Dtools=true,-Dtools=false,flex-native bison-native"
23PACKAGECONFIG[yaml] = "-Dyaml=enabled,-Dyaml=disabled,libyaml"
24
25PACKAGES =+ "${PN}-misc"
26FILES:${PN}-misc = "${bindir}/convert-dtsv0 ${bindir}/ftdump ${bindir}/dtdiff"
27RDEPENDS:${PN}-misc += "${@bb.utils.contains('PACKAGECONFIG', 'tools', 'bash diffutils', '', d)}"
28
29BBCLASSEXTEND = "native nativesdk"