summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/xkeyboard-config_2.8.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_2.8.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.8.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.8.bb
new file mode 100644
index 0000000000..8ca2f6aa2b
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.8.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI="${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
16SRC_URI[md5sum] = "e66d567d85a954d589c5723fb0e1f3dd"
17SRC_URI[sha256sum] = "4e1cf5468d488aaf320ddfd439e03cbda0b213550fd734026d23138e4b2078ae"
18
19SECTION = "x11/libs"
20DEPENDS = "intltool-native xkbcomp-native glib-2.0 virtual/gettext"
21
22PR = "r0"
23
24EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
25
26RDEPENDS_${PN} += "xkbcomp"
27FILES_${PN} += "${datadir}/X11/xkb"
28
29inherit autotools pkgconfig
30
31do_install_append () {
32 install -d ${D}${datadir}/X11/xkb/compiled
33 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
34}