summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/xkeyboard-config_2.14.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_2.14.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.14.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.14.bb
new file mode 100644
index 0000000000..a9607449f0
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.14.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2 \
16 file://0001-Remove-GPLv3-content.patch \
17 "
18SRC_URI[md5sum] = "2869c03d85b606f929aab054ef6e1b60"
19SRC_URI[sha256sum] = "dc91458a214c56a35727f9e523fc647615de64137057ca6ee4d4d4474a4bb2ae"
20
21SECTION = "x11/libs"
22DEPENDS = "intltool-native virtual/gettext util-macros libxslt-native"
23
24EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
25
26FILES_${PN} += "${datadir}/X11/xkb"
27
28inherit autotools pkgconfig gettext
29
30do_install_append () {
31 install -d ${D}${datadir}/X11/xkb/compiled
32 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
33}