summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb b/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb
new file mode 100644
index 0000000000..e13b9adffb
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Pixman: Pixel Manipulation library"
2
3DESCRIPTION = "Pixman provides a library for manipulating pixel regions \
4-- a set of Y-X banded rectangles, image compositing using the \
5Porter/Duff model and implicit mask generation for geometric primitives \
6including trapezoids, triangles, and rectangles."
7
8require xorg-lib-common.inc
9
10LICENSE = "MIT & MIT-style & PD"
11LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
12 file://pixman/pixman-matrix.c;endline=25;md5=ba6e8769bfaaee2c41698755af04c4be \
13 file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
14 "
15DEPENDS += "zlib libpng"
16BBCLASSEXTEND = "native nativesdk"
17
18PE = "1"
19
20IWMMXT = "--disable-arm-iwmmxt"
21LOONGSON_MMI = "--disable-loongson-mmi"
22NEON = " --disable-arm-neon "
23NEON_class-nativesdk = " --disable-arm-neon "
24NEON_armv7a = " "
25NEON_armv7a-vfp-neon = " "
26
27EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}"
28EXTRA_OECONF_class-native = "--disable-gtk"
29
30SRC_URI += "\
31 file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
32 file://mips-export-revert.patch \
33 file://asm_include.patch \
34 file://0001-v3-test-add-a-check-for-FE_DIVBYZERO.patch \
35"
36
37SRC_URI[md5sum] = "18d6b62abdb7bc0f8e6b0ddf48986b2c"
38SRC_URI[sha256sum] = "5c63dbb3523fc4d86ed4186677815918a941b7cb390d5eec4f55cb5d66b59fb1"
39
40REQUIRED_DISTRO_FEATURES = ""